mercredi 19 décembre 2012

Block openrc-0.9.9.3

Problème :

Lors d'une mise à jour , j'ai eu le problème suivant

[blocks B      ] <sys-apps/openrc-0.9.9.3 ("<sys-apps/openrc-0.9.9.3" is blocking sys-apps/net-tools-1.60_p20120127084908)

 * Error: The above package list contains packages which cannot be
 * installed at the same time on the same system.

  (sys-apps/net-tools-1.60_p20120127084908::gentoo, ebuild scheduled for merge) pulled in by
    sys-apps/net-tools required by @system

  (sys-apps/openrc-0.9.8.4::gentoo, installed) pulled in by
    sys-apps/openrc required by (dev-db/mysql-init-scripts-2.0_pre1-r2::gentoo, installed)
    sys-apps/openrc required by (sys-apps/baselayout-2.1-r1::gentoo, ebuild scheduled for merge)

For more information about Blocked Packages, please refer to the following
section of the Gentoo Linux x86 Handbook (architecture is irrelevant):

http://www.gentoo.org/doc/en/handbook/handbook-x86.xml?full=1#blocked

Solution :

Certain package (ex :net-tools) demandent une nouvelle version de openrc.Hors sur mon système, il y a une ancienne version  (openrc-0.9.9.3).il suffit donc de désinstaller openrc :

emerge -C sys-apps/openrc

Puis d'installer la nouvelle version :

emerge  sys-apps/openrc



PoweredByGento